Astra Pro with Skanect

I am trying to use Astra pro with Skanect which is OpenNI2 compatible. when i launch skanect it says
“structure sensor waiting for uplink”

when i copy astra drivers into Skanect folder is gives me green light and connected to Astra “laser appears to be on”
yet Skanect still doesn’t start processing 3D data.

Has any on had success getting this to work and how?

Thanks so much in advance!

PS Depth sensor works fine in SDK


I also notice this as well . Have also noted that this only works in the 32bit version that I could get going .

Hopefully we will have streams soon :slightly_smiling:

Has anyone managed to get this or the Astra S to work with Skanect? I have had 0 luck getting the Astra S to work with any OpenNI Software - just Recfusion and the scans have been poor overall - Since I own Skanect, was hoping the camera is good and the poor scans are Recfusions issue but can’t test with anything else…

it worked:

  • Only with 32 version of Skanect
  • Only after copying orbbec.ini and orbbec.dll in the Skanect 1.7\bin\OpenNI2\Drivers or just in Skanect 1.7\bin\OpenNI2
    I did for both

I got the both files after installing touchlesstouch in \Touchless Touch\OpenNI2\Drivers

Oh no!! the color camera doesn’t work. Maybe because these files are from touchlesstouch and they don’t need colors. But now with Skanect I can make just colorless scan.

Anyone has a solution? better files to replace?

as far as I know, the astra pro uses uvc for color image, which is not competiable with openni2, so no luck. I tried your mentioned solution, copy and paste both files to 32bit skanect but still cannot detect the sensor. could you share both files maybe? thx