Astra S - Installation/Setup Issues


I just bought an Astra S and I’m having a lot of trouble just getting the different camera streams to work.

So far what I have done:

1-Connected the Astra S to a USB port of my PC
2-Installed Orbbec Driver for windows provided on the website using the installer
3-Downloaded and ran the AstraUnity536Sample-Windows
4-I only get one frame inside the Color/RGB stream and all the other streams remain gray

I am able to see the Device ORBBEC Close Depth Sensor in Device Manager.

I can see the driver Orbbec installed properly in Programs.

What am I missing? This should be straight forward right? I have tried uninstalling and re-installing the driver but no luck…

My system information:

Version SMBIOS 2.5
Version BIOS/Date: American Megatrends Inc. 1611, 26/11/2008
Version 6.1.7601 Service Pack 1 Build 7601
User Daniel-PC\Daniel
Type PC x64
OS Microsoft Windows 7 Professionnel
Processor Intel(R) Core™2 Quad CPU Q8400 @ 2.66GHz, 2670 MHz, 4 cœur(s), 4 processeur(s) logique(s)
Total Virtual Memory 16.0 Go
Virtual Memory available 12.0 Go
Total Physical Memory 8.00 Go
Physical Memory available 4.42 Go

Don’t believe windows 7 is a supported system by many sensor devices these days

1 Like

Humm that could be the issue… I guess the only way to find out is to get windows 10 and test again… On Orbbec Wiki they say that Windows 7 is supported by the driver:

But the Astra SDK is only Windows 8 and 10, 32-bit and 64-bit

Let see if it works after I install Windows 10…


I bought a completely new PC with Windows 10 installed on it and it works now! Not sure if it was windows version or another component. But it is resolved! Thank you @wtatters !