Astra SDK Body Tracking Unity Crash


So one year ago I worked on a product that include the Astra and it’s body tracking sdk, after the trial expired I saw that the Astra doesn’t recognize bodies, so I discovered that it is licensed and need to be purchased separately. Of course we did so and after a long checks (no api or documentations on the matter provided) I found how to set the build with the license
and we sent 2 builds to a client with one license and for some reason it worked fine.

Today, the client reopened the application and saw that one of the builds didn’t work, of course my first solution is to buy new license for the client but now when I try to test it inside the Unity Editor with the license set, it crashes my Unity editor…

if I don’t set the license, everything works fine.
I said, ok maybe the SDK is old (one year ago) so I tested with the new SDK on new project, I set the license and tried to stop the application after setting the license, and boom unity crashes… again….

This is clearly a SDK problem, and the way that it’s accomplished inside is probably wrong… now it’s really hard for me to work on this product because I can’t check the license configuration or the body tracking without upgrading the SDK to fit the trial duration.

Another problem when I try to buy the SDK license and I’m going to the download page, it sends me back to the Develop page… So the link they give is broken and I can’t get the new license I purchased.

Please fix this!
Thank you.