Astra Stereo S - Problem with getting started

I’m trying to get started with my Astra Stereo S sensor but I’m having trouble.

Here’s what I know so far:

I started by installing the latest drivers & getting the AstraSDK from the website:

  • astra-win32-driver-

I tried the sample apps in the SDK, such as “bin\SimpleDepthViewer-SFML.exe”, but it doesn’t work:

Note that the same app works fine with my Astra Pro:

The astra-tests.exe sample in the SDK fails as well:

My device manager lists the device properly (though the driver date looks a bit outdated to me):

The light on my sensor is on:

Finally, I debugged the SDK sample code briefly and it seemed like the update loop in the BodyReaderPoll app was failing due to ASTRA_STATUS_TIMEOUT.

I could investigate further, and if I do and find a fix I’ll leave a note here…

But has anyone managed to get started with their Astra Stereo S? Is the Astra SDK and the drivers up-to-date to support Astra Stereo S?

From what I’ve heard, the Astra SDK did not work with Stereo S before April 1, 2019. It should be working now, though I have yet to try it.

I’ve also heard that the OpenNI SDK worked with Stereo S since day 1.

I had the same problem. The resolution is hard-coded to 640x480 in SimpleDepthViewer. Try changing it to 640x400.