Body tracking not working on some Windows 8.1


We had problems to run our application (that uses Astra SDK) in some Windows 8.1. I tried to run the samples provided in the SDK, and the samples involving Body Tracking do not work. When I run BodyReaderPoll.exe the camera does not switch on. However, DepthReaderPoll.exe is working fine.

Can anybody help me to find a solution to this issue?

Thank you

@fbit Have you installed windows updates?

How far are you from the sensor ?

Yes, I installed windows updates. However, there’s one update that failed to install. I am not a regular Windows user, so I am not very familiar with windows updates system.

It’s not a driver problem, because some samples are working. It’s only Body Tracking samples that are not working.

I don’t think that distance to the sensor is relevant here, because the camera does not even switch on.

@fbit Body Tracking uses additional libraries than the basic samples. I had similar problem with one of windows 7 computers, it was solved by updating windows media dlls. Maybe it’s your case.

Thank you for your reply. I don’t think I understand your suggestion. What are windows media DLLs and how can I update them? Sorry if I am asking a silly question :stuck_out_tongue:

@fbit Very simple, windows update installation will automatically update the media libraries (dlls), just try to complete the failed update

Finally, I succeeded to install all pending updates. However, the problem persists.

I even upgraded to Windows 10 and the problem persists. Any suggestion on this?