Camera suddenly stopped working

Hello, I have an Astra S camera that was functioning well until a week ago. Today, when I connected the camera, both my Windows PC and a Raspberry Pi, which I had been using previously, couldn’t detect the camera. Specifically, Windows is indicating that the USB device may not be functioning properly and is giving me error code 43. Have you any solution?

Have you tried to update the driver?
Any screenshot of the device manager?

I tried to update driver and no results. Camera can’t be detected from windows and from Raspberry too where I worked with it still one week ago. I tried also Orbbec Viewer but no results. Screenshot:

Sorry for italian :sweat_smile:

You could try to reinstall the latest driver from our website


May need to unplug the camera and completely power off (unplug) the PC. You may also check if anything else is accessing the camera. We’ve seen if something else (say Windows Camera app) access the camera while the OrbbecSDK has it open it can break the camera at the driver level like this. This happens for us on the Astra2 with the OrbbecSDK, so may not apply here.