Can I develop/test applications with Persee connected to a PC

I am feeling a little lost here.
I have received my Persee with Android installed.

Wi-fi will not connect (finds the router, but after a while messages : connection failure). Using ethernet cable.
I have connected the HDMI cable to a monitor and a mouse to the device so I could see some applications.
Camera application works, but multstream application does not work for RBG camera.

Downloaded the Astra SDK but I am not sure HOW TO (if possible) TEST/DEVELOP APPLICATIONS for Persee since it seems I can’t connect Persee directly to a PC. Is that correct?

Any instructions for getting starting here? How to upload applications to Persee? Can I use any IDE? Xcode? or I have to use Android Studio?

1 Like

I would also like to know. My hypothesis is that you must write the code on a pc and then upload the .apk file to the Persee using a USB flash drive or other external memory storage device.

Dear all,

I’m in the same situation here.
I would like to develop an application on Android to analyse the skeleton tracked by Nutritrack, record RGB and depth videos on a server and so on.
Can someone help please?
Any doc exists with basics examples of how develop on Persee with Android?

Thank you!

To all,

I am in the same wagon. The other issue that I have is that I connected mine to the PC and I was able to boot up the android environment with the sample applications. After I played with it, it rebooted and now it is stuck with the display only showing the logo blinking. Did anybody had the same issues? I also connected the camera to the power supply and the hdmi but I got the same situation, it seems like the camera is stuck.

Thank you for any feedback you may have,


I’m also interested in this. We recently bought a Persee for evaluating whether it could be a good replacement for our Kinect solution that we have today.

Will it be possible to connect Persee to android studio, the same way you do when testing on phones? I’ve tried to set the Persee in Development mode with USB enabled but the device cannot be found from android studio. I’m running on a mac.

You can connect to the Persee via Micro USB.
However, it does not detect the connection automatically. You have to disable and re-enable USB debugging while the USB cable is connected.

Hello, @kaasa.abdul.

I also using android studio on Mac, I tried your approach but its not work for me. My android studio version is 3.1.2 and my Mac version is 10.12.6. Anyone have solution for accelerating the debug and development. I hope it can test on the persee instantly. Thanks

How to disable and re-enable USB debugging while the USB cable is connected?

Never its too late! Thanks.
Wow…It took more than 2 years for that lol.
I wonder if this company was really worried about people getting starting.
I kind of regret had supporting their crowdfunding.

You do that like on any Android device: On the device, open the Settings app, select Developer options, and then disable and re-enable USB debugging.