Device open failed after building SDK

I am following the steps to build the SDK in linux. When i run ./SimpleViewer, I get the following:
$ ./SimpleViewer
After initialization:

SimpleViewer: Device open failed:
DeviceOpen using default: no devices found

Is it because the persee has not been detected by ubuntu.
Is there some method to check whether the sensor has been detected? Or is there something else to be installed/done?
When i type dmesg | grep tty, I get nothing different when the persee is connected or not connected.


Do you connect a Persee to a linux computer? Or are you running linux on a Persee camera?

currently, persee to a linux computer. But later will run linux on a persee camera.
What are the differences in the two steps?

Persee is a computer and a camera. if you give power to it and connect it to a monitor it can work in itself. There’s no need to use another computer. I don’t think it works that way.

Agreed. But the linux astra driver allows you to connect persee to linux and view the stream from the camera.
As given in the steps here:

Are you familiar with this? If so, guide me about some step that i may have skipped.

I have never tried this, I didn’t think it would work that way, and I’m still not sure if it is possible. I think OpenNI2 should be installed on the device itself. But I might be wrong.

I repeated the same steps on Persee. I ran the SimpleRead sample from OpenNI-Linux-2.3.

Still, I got the error:
ease$ ./SimpleRead
Couldn’t open device
Could not open “2bc5/0403@1/4”: Failed to open the USB device!
Why did this happen?
Did I miss some installation?
Also, what do you mean when you say OpenNI2 must be installed on the device itself.


Maybe you need install device rules. Can you run SimpleRead with sudo?

Thanks for all the help, gaborpapp.

Did you fix this issue? … Because I have same problem now !!