Femto Mega not detected when connected via Ethernet

Hi, I am trying to connect my Femto Mega using ethernet but its not being detected in orbbec viewer or k4aviewer. The camera is detected by both when connected via USB. I have the same problem with the camera connected directly to my laptop via ethernet and powered by the barrel jack plug and through connecting the camera via POE. The light indicator is solid white so the camera itself does seem to detect a connection.

please ref K4A Access Femto Mega Network Mode - ORBBEC - 3D Vision for a 3D World

I tried that it still doesn’t seem to be detected.

[02/20 10:42:52.198343][info][6628][Context.cpp:69] Context created with config: C:\Users\usmankhan\Desktop\OrbbecSDK_K4A_Wrapper_v1.9.1_windows_64_release_2024_1_30\OrbbecSDKConfig_v1.0.xml
[02/20 10:42:52.198449][info][6628][Context.cpp:74] Context work_dir=C:\Users\usmankhan\Desktop\OrbbecSDK_K4A_Wrapper_v1.9.1_windows_64_release_2024_1_30
[02/20 10:42:52.198556][info][6628][Context.cpp:77]     - SDK version: 1.9.4
[02/20 10:42:52.198688][info][6628][Context.cpp:78]     - SDK stage version: main
[02/20 10:42:52.198833][info][6628][Context.cpp:82] get config EnumerateNetDevice:true
[02/20 10:42:52.198975][info][6628][MfPal.cpp:102] createObPal: create WinPal!
[02/20 10:42:52.646664][info][6628][GVCPClient.cpp:223] bind
[02/20 10:42:53.682360][info][6628][DeviceManager.cpp:15] Current found device(s): (0)
[02/20 10:42:54.702892][info][6628][Context.cpp:90] Context destroyed
No k4a devices attached!

It’s not detected in orbbec viewer either when i try to connect a network device and input the IP address.

[02/20 10:58:10.955642][warning][5200][ObException.cpp:5] VendorTCPClient: Connect to server failed! addr=, port=8090, err=socket is not ready & timeout
2024-02-20 10:58:10.956 ERROR [5200] [OBSensorServer::addNetDevice@420] function:ob::Context::createNetDevice
args:address:1, port
message:VendorTCPClient: Connect to server failed! addr=, port=8090, err=socket is not ready & timeout

It needs to be a LAN environment,In the same subnet

When I try to change the IP settings of the device, I get this error in orbbec viewer,

2024-02-21 09:24:09.481 ERROR [21392] [CurlUtil::firmwareListGetCurl@213] Response is null
2024-02-21 09:24:09.482 ERROR [21392] [UpgradeOnlineServicer::CheckFWVersion@28] Get firmwareList is Failed!
2024-02-21 09:24:09.483 ERROR [21392] [UpgradeOnlineServicer::OnlineUpgradeDetection::<lambda_c98381bd685d70faa3f341062b28649d>::operator ()@87] Check firmware of version Failed!

I am on firmware 1.2.7 and SDK version 1.9.4.

Even in the same subnet and in LAN environment I get the same problem as my other reply.

Hi Please Update firmware 1.2.8 It’s tested
Release Release Femto Mega Firmware · orbbec/OrbbecFirmware · GitHub

@usmank Hello, After updating the firmware, whether the problem has been resolved?