First test in Unity 5.5.4


How to run TestScene or TestScene2 in Unity on Windows 10?
Did someone had success?

I’m getting different errors, when I unplug/plug the device:

  1. Can’t initialize Streams… spams Debug Log.

IndexOutOfRangeException: Array index is out of range.
AstraController.InitializeStreams () (at Assets/Scripts/AstraController.cs:132)
AstraController.OnAstraInitializing (System.Object sender, .AstraInitializingEventArgs e) (at Assets/Scripts/AstraController.cs:118)
AstraUnityContext.RaiseInitializing () (at Assets/Scripts/AstraUnityContext.cs:157)
AstraUnityContext.Initialize () (at Assets/Scripts/AstraUnityContext.cs:76)
AstraController.Awake () (at Assets/Scripts/AstraController.cs:96)

  1. In Device Manager is ORBBEC Depth Sensor but under Universal Serial Bus controllers is:
    Unknown USB Device (Device Descriptor Request Failed)
    This happens sometimes.
    Error in Unity in the same as under 2)
    At 1) and 2) in Device Manager everything looks fine.

  2. In Device Manager:
    Orbbec(R) Astra™ Audio Devive (Yes, it is not Device, it says Devive)
    has an error.
    Error in Unity in the same as under 2)

I’ve tried to delete driver and install it again. It didn’t helped.

The best shot was after restarting PC. When I click Play in Unity I can see that IR LED’s are ON but Unity is stuck. Nothing happens and hangs out (processor usage is 0%). If something is near to the sensor, LED’s are turned OFF and later turned ON again. It seems that it working but can’t run TestScene…
I’m using USB2.0.

I thought that connecting will be easy so I can jump in Unity and play with it. But I lost whole day instead, so far…

Problem was front USB port, any of front ports. After I connected Orbbec to the back side of the PC it worked.

1 Like

Are your USB ports at the back using USB 3.0?