How do we fix our flickering depth image when using an Orbecc Astra Camera and Rviz?

Hello everyone,

We try to set up the Orbbec Astra Embedded S camera with ROS and our goal is to detect objects by reconstructing a 3D point cloud from the camera images. We are using ROS Noetic and the ROS-Package “astra-camera” ( as well as Rviz to visualize the images and the 3D point cloud.

Here are the rostopics:

  • /camera/color/camera_info
  • /camera/color/image_raw
  • /camera/depth/camera_info
  • /camera/depth/image_raw
  • /camera/depth/points
  • /camera/ir/camera_info
  • /camera/ir/image_raw

First Issue:

The color (/camera/color/image_raw) and IR (/camera/ir/image_raw) image stream seems to be working fine, but the big issue is the depth (/camera/depth/image_raw) image stream as it is flickering very fast and does not seem to detect anything.

Second Issue:

When launching the camera by running “roslaunch astra_camera astra_pro.launch” we received three warnings:

  1. Publishing dynamic camera transforms (/tf) at 10 Hz
  2. Camera calibration file /home/astra/.ros/camera_info/rgb_camera.yaml not found.
  3. Camera calibration file /home/astra/.ros/camera_info/ir_camera.yaml not found.

By calibrating the color camera using a checkerboard, we were able to solve the 2. warning, as it generated the rgb_image.yaml file containing the intrinsic parameters. We tried calibrating the ir camera as well, but the ir_camera.yaml file was not generated. We have not yet solved the first warning.

Even though we are unsure if this is related to the issue regarding the flickering depth image stream, we believe it is worth mentioning.

We are ROS beginners and would be grateful for any feedback that could help us to find
a solution. If you need any other or more information, please let us know.