Install Ubuntu on Persee

Hello, I just got my Persee, but it came with Android.

What is the recommended way to install Ubuntu?
Where can I download the relevant drivers?

Thanks!

Hi rocha,

Thanks for your input. Our engineers are currently working hard on bringing Ubuntu to our customers. There are still some small tweaks need to be finished before the official release. It will be released very soon.
Sorry for any inconvenience.

Jackson

Thanks for the update. I’ll wait for the official release then.

I’m trying to follow the directions in the Persee Update ROM Guide.docx file from the Persee Image Installation Guide.zip bundle. The instructions seem to be Android-specific, but I gave it a shot anyway.

I installed the Rockchip driver and tried using AndroidTool to flash the Ubuntu image. After plugging in the Persee over micro USB it says “Found One ADB Device,” but I’m not sure about the ADB commands and whether they’re relevant. When I select the Ubuntu img file and click “Upgrade” I get the following error: Match device type failed, stop running!

Is there some additional setup information for flashing Ubuntu onto the Persee? Also does it require Windows? I’m able to try from OSX or Linux (Raspian :slight_smile: ) as well

Hi mattfelsen,

Thanks for asking. You will need to use a small pin to hold the reset button, which is located at the left side of the DCIN port while plugging in the micro USB cable to the computer. It will be recognized as a loader device in the tool.

Jackson

Got it, thank you. I was able to get Ubuntu running when flashing from Windows.

I’ve run into a separate issue: plugging in an ethernet cable works to get me online, but I’m having trouble connecting to a wifi network. It seems to always reject the password and pops up the dialog to enter the password again – I’m positive I’ve typed it correctly and have tried on two different networks. In addition, another dialog pops up asking for a password to a Default keyring or something like that. I’ve tried a space, “orbbec”, and “persee” but none of them seem to be correct. Any thoughts here?

Did you change password? When you change the password for user orbbec, you have to change its default keyring password as well.

Otherwise, connect to Wifi network → it will ask for keyring password, unlock the keyring using original password → connect to Wifi network again.

Hi

I have experienced the same problem, but after trying several times I could finally connect to the wifi.
The default keyring password is a space since I haven’t changed the password yet.
The wifi works for me.
Cheers

Thanks for the replies @zhumxcq @sarah. I haven’t changed the password – I’ll try the wifi a few more times.

I had the same problem persistently. Solution for me was to “disable wireless” and “disable networking” then “enabled networking” and “enable wireless”. These menu items are under the right click menu of the network icon in the task bar.

At the same time I also tried connecting to a second network (e.g. a mobile hotspot) then again connecting to the first network. This may have helped or not, not really sure. You can try both solutions.

The one-time appearing dialog for creating a keyring password is not relevant to the problem. The passwrod you enter there (twice with the confirmation) does not have to be the same as the root password, but having the same password (space) would help in remembering.

Hope this helps, Cheers!

Turgay

Hi mattfelsen,

I just got Persee today but the OS is Androi (my expectation is Ubuntu).
Can you share me how to install ubuntu on Persee

I’ve run NiViewer on Android OS to see the depth frame but the quality is poorer than Kinect (Both V1 & V2).

Thank you so much!

hello mattfelsen,

I am also getting the same ‘found one ADB device’. Even after multiple attempts of reset and connecting micro USB cable, i am not able to get it as LOADER device. Did you face this issue too? Can you share something different that you may had to do?

Thanks,
Garv

hello Jackson,

I am also getting the same ‘found one ADB device’. Even after multiple attempts of reset and connecting micro USB cable, i am not able to get it as LOADER device. Is there something different that i should try?

Thanks,
Garv

I’d recommend trying the rkflashkit / upgrade_tool on Linux. I’ve documented the whole flashing process I had to go through here: Compiling Persee kernel and flashing it on the Persee. Would be nice if someone figured out how to do the upgrade_tool’s work by using rkflashkit

hi jesse

thanks for your reply. I followed your thread and downloaded upgrade_tool.
I connect my device and ./upgrade_tool shows it in loader state.
now i try to use the uf command in rockusb. Instead of update.img, i give my ubuntu image.
It starts to load firmware and displays FW version and all.
however, i am getting the error: Creating comm object failed!

do you have any idea why is this happening?

I’m afraid not. As the upgrade_tool is not open it’s hard to really debug it. I’d take a look at the output of dmesg and analyze it to see if there’s anything obvious going on.

Hi,

Can someone point out the direction on how to enable/add the Memory Controller Subsystem in /sys/fs/cgroup in Ubuntu 16.04?

The current default subsystems are as below.

ubuntu@localhost:~$ ls /sys/fs/cgroup
cpu cpu,cpuacct cpuacct debug freezer systemd

Hi,

You need to reset the power supply to the Persee as well (restart it). So, remove both the usb and power in cables first. Hold the pin down and then plug in the DC IN cable and micro USB cable. That worked for me!

Raki

Where can I donwload an Android image to revert the Linux install on Persee?

1 Like

I hope it helps!