Integration in android Studio Project

I want to integrate astra sdk into my android application,
i downloaded code from GitHub - orbbec/astra: Orbbec Astra SDK - build amazing 3D apps with Orbbec 3D cameras. How to integrate in android application? can you give me some steps ?

Hello Sir,
I have tried this code
But not success yet.

Can you please guide me from starting ?


E/AndroidRuntime(31006): Process:, PID: 31006
06-23 12:22:25.441: E/AndroidRuntime(31006): java.lang.UnsatisfiedLinkError:
dalvik.system.PathClassLoader[DexPathList[[zip file “/data/app/”],nativeLibraryDirectories=[/vendor/lib, /system/lib]]] couldn’t find “”
couldn’t find “”
couldn’t find “”

I have successfully integrated project in eclipse with no error.

but i think its not generating .SO files so far. while executing simpleviewer sample i am getting error as given above.

Please guide me to succeedd…

Finally Got sollution…

Thanks… its working now …

Really thankful to you

> how can we use gesture control ?
> Means i want to detect gesture behavior and based on want to change app behavior ?
> can you give me developer guide or any suggestion ?

Hello sir! I am new to orbbec and I have followed your way of building the openni2 sample.
However I got this:
Creating installer for OpenNI 2.3 Android
Building Wrappers/java… OK
Building Samples/SimpleRead.Android… Failed to execute command: [‘ant’, ‘-f’, ‘…/Samples/SimpleRead.Android/build.xml’, ‘release’]

I have try your solution, it still not work. When I tap “ant” into terminal and press enter: it gives me this:
Buildfile: build.xml does not exist!
Build failed
And I could not use Android Studio to run the too.

When I run in Android Studio, it gives me this:
make: *** No rule to make target /Users/gaocan1992/.../OpenNI2/Samples/SimpleRead.project/openNIForAndroid/build/intermediates/ndk/release//Users/gaocan1992/.../OpenNI2/Samples/SimpleRead.project/openNIForAndroid/src/main/jni/OpenNI.jni.cpp', needed by /Users/gaocan1992/…/OpenNI2/Samples/SimpleRead.project/openNIForAndroid/build/intermediates/ndk/release/obj/local/armeabi/objs/OpenNI2.jni//Users/gaocan1992/…/OpenNI2/Samples/SimpleRead.project/openNIForAndroid/src/main/jni/OpenNI.jni.o’. Stop.

its Eclipse project not android studio project…
In eclipse its working fine …

hi ,It is really that using orbbec with nite to get the skeleton,how to do ?thank you

Have a try ! Thank you very much !