Multiple sensor color image problem

Hello everyone! I’m trying to develop an application that needs multiple sensors, but I’m getting no color from one of the sensors.

Even when I run the MultiSensorViewer-SFML example, I can see no image from one of the sensors. I’m using the Astra Stereo S U3 model.

I really need to get this to work.

Thanks in advance.

The same is happening in my application.

this time i tried with 3 sensors, and it seems that only “device/sensor2” works in the case of 3 sensors, and “device/sensor1” in the case of 2 sensors.

Hello.

I found out an interesting thing.

I am also testing with Astra Mini S sensors, and when I connect 2 of them, the example works.
When I connect one Mini S, and one Stereo SU3, both work too.

The problem is when I connect two or more Stereo SU3. In this case, it does not work properly.

I suppose it’s a problem with the sdk or the library. Seems unlikely to be a problem with my computer.

Any suggestions/solutions?

Thank you very much.

There should not be any problem when working with multiple stereo su3 (because the nature of active stereo IR). HOWEVER, astra stereo su3 have an initial distance from its inertial frame to the object analyzed (I think it’s 25 cm), so, in order to work with them, its FOV’s distal point must be greater than that initial length, otherwise it will return a 0 matrix.

From my experience, the MultiSensorViewer-SFM sample didn’t handle multiple color stream from UVC RGB sensor case. Stereo U3 has UVC RGB sensor, however, the Mini and Mini S has non-UVC RGB sensor. I use the SN of Stereo U3 to differentiate the multiple RGB sensors so my application can output two depth streams and two color streams simultaneously.

Thanks for sharing it!

However, it is unclear to me how can I “differentiate the multiple RGB sensors”.

Are you using the C++ SDK? If so, could you please leave some code snippet so I can try your solution?

Thank you

It’s not related to the sensor functioning itself, my guess is that it’s related to the data access by the library