Open device failed - no devices found


I’m trying to compile and run the OpenNi sample programs on Windows 8.1 - for example ClosestPointViewer.
I downloaded Orbbec OpenNi, and executed SDK/samples/bin/ClosestPointViewer.exe and it worked (it displays a window that keeps track of the closest point to the camera).
Then I opened the source code project by ClosestPointViewer.vcxproj in Visual Studio 2017 and compiled it successfully (after adding lib and include paths).
The problem is when I run the code I get this error:

Open device failed:
DeviceOpen using default: no devices found

This also happens in other samples, such as SimpleViewer.

Any help is appreciated

Hi alaa137,

Please make sure the driver is properly installed before launching the sample. The driver can be found from the link below.

Hi Jackson,

Thanks for the reply. The driver is already installed:

Also note that some of the pre-built examples work. It’s just the ones that I compile don’t.

Any help? I’m still getting a “no devices found” error even though the driver is installed successfully.

Have you tried to use HUB instead of directly connection to the USB port?

You can’t be serious man

In my case it helped