Persee apparently don't turn on

Hi, i dont know if this is a newbie question but i connected the camera to the power supply and to the hdmi, and i am not able to make it work, i tried to use the android tool to update the firmaware but still getting the No Devices found, There’s something i should be looking for to validate that my camera is working properly?

thanks a lot!

I’m also having a similar issue. Here are the things that I’ve tried:

  • Followed instructions from Persee Update ROM Guide.docx.
  • After installing the driver I ran the AndroidTool.exe but it always shows “No Devices Found”
  • Using a PIN and hitting the small button beside the DCIN port
  • Re-plugging power cable and micro usb cable

Any help would be much appreciated!

Hi, please try to restart the computer after the installation of the driver. The power cable is not required during the system installation process. Simply use a pin to hold the small button near the DCIN port while plugging in the micro USB cable. The Persee will be shown as a “loader device” in the AndroidTool.