Problem with multiple Dabai cameras

I am attempting to use two Dabai cameras on the same computer but I’m encountering a critical issue. Here’s what I have done so far:

  • I checked the serial numbers using the command: “rosrun orbbec_camera list_devices_node”. It found two devices, but only one serial number is shown. The other one appears as an empty string. However, both USB ports are displayed as expected. Therefore, I decided to use the USB ports instead.
  • modified the multi_camera.launch file with the USB ports, 3D sensor settings, and device_num . Initially, I only ran one device, even though I had plugged in two cameras. Everything worked as expected in this configuration. However, when I tried to run both devices by setting device_num to 2 and uncommenting the relevant code, it raised an error: ‘Failed to start device: No required type sensor found! SensorType: OB_SENSOR_IR’ for both cameras.
  • Moreover, once this error occurred, I couldn’t run anything anymore, not even in the single-camera mode (always raises the error Failed to start device: No required type sensor found! SensorType: OB_SENSOR_IR). I could only resolve this issue by rebooting my system. However, the problem with using two cameras still persisted.

Note: I am using the latest code from GitHub - orbbec/OrbbecSDK_ROS1: OrbbecSDK ROS wrapper

1 Like