RGB Issues ROS Package

I am using the Orbbec Astra Pro with Ubuntu 18.04 and ROS Melodic. I am using the astra_camera package from GitHub - orbbec/ros_astra_camera: ROS wrapper for Astra camera.

When I run astra.launch I can then run rosrun image_view on /camera/depth/image, but when I try the IR topics or RGB topics I don’t see anything. No error messages either. I have copied the results from running roswtf both on the astra_camera package and from my home directory. I have libuvc installed, so I am unsure if that error is the issue.

nvidia@nvidia-Inspiron-7373:~/catkin_ws/src/ros_astra_camera/include$ roswtf
Loaded plugin tf.tfwtf
Package: astra_camera
Cannot find dependencies for package [astra_camera]: missing libuvc
ROS path [0]=/opt/ros/melodic/share/ros
ROS path [1]=/home/nvidia/catkin_ws/src
ROS path [2]=/opt/ros/melodic/share

nvidia@nvidia-Inspiron-7373:~$ roswtf
Loaded plugin tf.tfwtf
No package or stack in the current directory
Static checks summary:

No errors or warnings
Beginning tests of your ROS graph. These may take a while...
analyzing graph...
... done analyzing graph
running graph rules...
... done running graph rules

Online checks summary:

Found 1 warning(s).
Warnings are things that may be just fine, but are sometimes at fault

WARNING The following node subscriptions are unconnected:
 * /camera/camera_nodelet_manager:
   * /camera/rgb/camera_info
   * /camera/rgb/image_raw

Additionally, I have tried the astrapro.launch file, but it fails with the following error:

[camera/camera_rgb-2] process has died [pid 19952, exit code 255, cmd /home/nvidia/catkin_ws/devel/lib/astra_camera/camera_node /camera/image_raw:=/camera/rgb/image_raw __name:=camera_rgb __log:=/home/nvidia/.ros/log/f0c5e520-e314-11ea-9ce9-44032cfc753d/camera-camera_rgb-2.log].
log file: /home/nvidia/.ros/log/f0c5e520-e314-11ea-9ce9-44032cfc753d/camera-camera_rgb-2*.log