SimpleViewer Sample Error (RPi3 + Ubuntu Mate 16.04.1 LTS + Orbecc Astra)

I just followed the Read Me instructions from Developers - ORBBEC - 3D Vision for a 3D World (OpenNI 2 for Linux)

I installed the OpenNI-Linux-x64-2.3 version

I ran through all the steps and when I ran the sample I got the following error after these steps:


add environment variables

$ source OpenNIDevEnvironment

build sample(e.g., SimpleViewer)

$ cd Samples/SimpleViewer
$ make

cp -R /home/sheppi/OpenNI-Linux-x64-2.3/Redist/* Bin/Arm-Release
g++ -o Bin/Arm-Release/SimpleViewer ./Bin/Intermediate/Arm-Release/SimpleViewer/Viewer.o ./Bin/Intermediate/Arm-Release/SimpleViewer/main.o -LBin/Arm-Release -lglut -lGL -lOpenNI2 -Wl,-rpath ./
Bin/Arm-Release/ file not recognized: File format not recognized
collect2: error: ld returned 1 exit status
CommonCppMakefile:139: recipe for target ‘Bin/Arm-Release/SimpleViewer’ failed
make: *** [Bin/Arm-Release/SimpleViewer] Error 1

When I try to do the next steps:

run sample

connect sensor

$ cd Bin/x64-Release
$ ./SimpleViewer

the Bin folder exists but not “/x64-Release”, but instead an “Arm-Release” with OpenNI and Drivers sub and sub-sub folder…

the other folder in bin is: /home/sheppi/OpenNI-Linux-x64-2.3/Samples/SimpleViewer/Bin/Intermediate/Arm-Release/SimpleViewer

Any ideas how to get this working properly?

and SimpleViewer is in

Hi Ryan,

I had the same problem. You need to use (for reasons that seem odd to me) the non 64 bit version i.e. OpenNI-Linux-2.3 not x64version on the Pi.

I’ve got SimpleViewer (SimpleReader has timing issues too) working not but it is dog slow (as per one of my posts) waiting to hear on that front.



Raspberry Pi utilizes an ARM based processor. Please use OpenNI-Linux-Arm-2.3-without_filter for better performance.


Just FYI - There is no performance difference between OpenNI-Linux-Arm-2.3-without_filter and OpenNI-Linux-Arm-2.3. Both are poor