Unable to locate packages when installing Astra Pro camera on Raspberry Pi

I have Raspberry Pi 4 Model B with 4GB RAM running Raspbian OS version 10 (buster). I have issues installing the Astra Pro camera. I following the instruction here. First I install ROS Melodic (Desktop variation /rosversion: 1.14.10), followed this instructions, and then when I try to install the rod_astra_pro package’s dependences I’m getting “Unable to locate packages”.

pi@raspberrypi:~ $ sudo apt install ros-$ROS_DISTRO-rgbd-launch ros-$ROS_DISTRO-libuvc ros-$ROS_DISTRO-libuvc-camera ros-$ROS_DISTRO-libuvc-ros
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package ros-melodic-rgbd-launch
E: Unable to locate package ros-melodic-libuvc
E: Unable to locate package ros-melodic-libuvc-camera
E: Unable to locate package ros-melodic-libuvc-ros

I tried to do “get apt update” or installing the packages individually (according to section 4.2 in to the ROS Melodic instillation instructions above)

I’ve tried to install from source, but it was bit hard and I have trouble with is.
I will appreciate any help I can get. I need the camera to do SLAM for the robot I’m building.