Using Astra SDK in a DLL

I run into a peculiar problem. When I was polling in a normal C++ program everything works fine. But when I call get_latest_frame() in a DLL, somehow it got stuck forever. Would anyone help tell me why? Thank you very much.

I had a similar (the same?) problem and I never got the solution to fix it. I finally gave up and I am not using it as a DLL.

Looking at debug messages I found a Warning saying that Plugins folder was not found. The very same code run as a C++ program does not show this message. Are you getting the same warning?

Using MS Windows Process Monitor to monitor disk accesses, I saw that if I ran the SDK as a DLL, Windows response to Plugins folder access request was an “INVALID NAME”. If I ran the same code as a single EXE file, the same request had “SUCCESS” as result.

If you find a way to fix this, pleas tell me. I haven’t been able to do it.

Thanks so much for your reply. I just remembered I forgot to put the OpenNI and plugin folders into where the program is. Without your reply I could never have figured this out.