V0.5.0 SDK samples (including Depth only) on OSX 10.13 show a black window for Astra Pro

I’m using the astra Pro on a macbook pro 2017, osx 10.13.2. (The camera is connected through a TB3 dock)
With a fresh download of the sdk v0.5.0, building and running the samples results in a blank/black window shown for SimpleDepthViewer-SFML, SimpleStreamViewer-SFML and SimpleColorViewer-SFML.

It does work correctly as a webcam (via FaceTime/etc.)

Also, when I downloaded the astra repo and built the samples there, I get the same result.

Additionally, when I try to use it with openni2 in opencv3.4 (using the liborbbec.dylib and orbbec.ini from vendor/openni2/), I get the following error:

OpenCV Error: Unspecified error (OpenCVKinect: Device open failed see: 	Could not open "2bc5/0403@0/13": Failed to open the USB device!

) in CvCapture_OpenNI2, file /tmp/opencv3/opencv-3.4.0/modules/videoio/src/cap_openni2.cpp, line 237
VIDEOIO(cvCreateCameraCapture_OpenNI2(index)): raised OpenCV exception:

/tmp/opencv3/opencv-3.4.0/modules/videoio/src/cap_openni2.cpp:237: error: (-2) OpenCVKinect: Device open failed see: 	Could not open "2bc5/0403@0/13": Failed to open the USB device!

 in function CvCapture_OpenNI2

Is there anything else I can try?

We tried on a co-worker’s Macbook pro (older) using a direct USB connection, and the SimpleDepthViewer works in that case.
He was also running OSX 10.12.6.

We then tried on my computer, but through an alternate USBC->USB3 dongle (instead of the original TB3 dock), and the depth viewer works in this case.

See here: [Megathread] Newbie FAQs (Astra PRO)

Long story short, SimpleDepthViewer-SFML sample should work but MultiSensorViewer-SFML and SimpleColorViewer-SFML will be black on MacOS due what sounds like an issue in the SDK for Mac. You can use UVC (webcam) if you require colorframes

Not sure about your OpenCV/OpenNI trouble