OpenGL problems with Persee

I have two Orbbec Persee’s. I have installed Ros Jade on both, and created a ROS node with the Simpleviewer project. I was required to apt-get install Freeglut3-dev and and ti get the system to build.

Once successful, one of my Persee’s works and displays the depth data in an OpenGL window. On the second system, I get the following error:

freeglut (/home/orbbec/catkin_ws/devel/lib/simpleviewer/simpleviewer_node): OpenGL GLX extension not supported by display ‘:0.0’

When I run glxinfo I get:

orbbec@orbbec:~/catkin_ws$ glxinfo
name of display: :0.0
Error: couldn’t find RGB GLX visual or fbconfig
Error: couldn’t find RGB GLX visual or fbconfig

On the system that works, glxinfo gives me a lot of data.

What makes it even stranger, is that on the system that works, the OPenGL samples in the sample folder all fail to run, and on the system where the SimpleViewer fails, the OpenGL samples all run when executed with sudo.

Any thoughts on where I can look to solve my problems? Has anyone else run into these problems? I am at a bit of a loss as to the cause since I installed both systems identically.

Hey Mirmathrax !

I had a simmilar Problem with the Developer Board -

Ros Indigo Desktop problem on Astra Developer Board.

After Installing Ros Indigo, The Symbolic Links to the OpenGLE Graphic Driver were changed.

I pointed them to the orginal ones again so both ROS & OPENGL Samples worked.

I am wondering if the X11 ARM Mali760 Graphic Drivers are built in the Lubuntu Distribution on the persee.
Or if its our job to check them from here ( ) and get them working…

So also in a fresh Lubuntu Start of the persee i don’t get WEBGL working in the chromium Browser, in android it was possible.