Orbbec Astra-S - distorted depth image

Hi all,
I’m using Orbbec Astra S in Linux environment. Everything works nice, however I noticed that the depth image is distorted at certain distance from the camera.

I’m enclosing some screenshots to describe this situation a little bit. There is always a step-like distortion in range between 647mm and 656mm from the camera. Regardless if I am using PIXEL_FORMAT_DEPTH_100_UM or PIXEL_FORMAT_DEPTH_1_MM.

The resulting model is shown below. As you can see, here is the step distortion really dominant. I double checked my code if there is possibility that this occurs because of bug in code. But the distortion is already present in depth image that comes from the camera.

I am using SDK from Orbbec Dropbox repository at Dropbox - Error - Simplify your life.

Both Linux 32bit SDK as well as 64bit SDK are affected.

Anyone encountered with the same issue? I have a suspicion that 16-bit unsigned integer is overflowing somewhere, since 656mm almost perfectly match to maximum value of 65,535.

Here is how I read the depth information:

cv::Mat_<double> depthMatrix(DepthHeight, DepthWidth)
if (depthStream.isValid() && depthStream.readFrame(&depthFrame) == openni::STATUS_OK) {
    const openni::DepthPixel* depthData = (const openni::DepthPixel*)(depthFrame.getData());
    for (int r = 0; r < DepthHeight; r++) {
        for (int c = 0; c < DepthWidth; c++) {
           depthMatrix(r, c) = depthData[DepthWidth*r + c];

Thanks in advance,
best regards,

1 Like

Hi, it seems that Astra SDK For Windows is affected as well. See the screenshot:

There is a clear step at the distances between 646mm and 656mm. I tried two computers, two sensors, OpenNI2 on 32-bit linux, OpenNI2 on 64-bit Linux as well as Astra SDK on Win8.1.



I get the same issue using Win7 on 32bits

Any idea on how to improve this?



1 Like

Can confirm, the step is exactly 10 mm, from 646mm to 656mm, I am using the preview version of Astra S shipped before Oct 2015, can anyone with Astra S shipped after Oct 2015 confirm this is still a issue?

1 Like

Yes, I can confirm it with an Astra Pro from 2015-11-07 (according to the Serial number) and with an Astra S from 2015-12-03.

Astra S:

We used OpenNI2 on Windows 7 64-bit.

1 Like

I received 2 Astra pro devices last week and both exhibit exactly this issue. I’m running on Arch Linux, and I’m using the pre-built Open-NI libraries.

I have the same issue with at least two Astra Pro, dated 2015-12-15, the jump occuring between 1287 mm and 1327 mm

+1 We see the same behavior. At ~1.4m, subject passes through an area where distance computation is missing, then it appears again.

We are getting the same problem here with a batch of Astras, shipped somewhen around October / November 2016.
It is easily reproducible by pointing the sensor to a flat surface at angle.

Is it a firmware issue of that batch and can be fixed?

Anybody got a solution?

Pictures of the issue:

we have the same issue. I am not sure if it affects all of our Astras.
the same problem has been discussed here: Diagonal ridge in point cloud

Hi Guys, is this issue resolve at all? I have purchased Astra S in 2016 and didn’t use it because of this artifact. Want to try the camera again, but need to know if Orbbec remedied it or not.

Hi bradd0,

This has been resolved for cameras shipped in 2018.

Hi Jackson,

Thanks for the answer. Can we make it work on my camera (2016 version) by the firmware upgrade? or should I purchase the new Astra-S in 2018? For the purchasing option, can I return my old camera and get refunded?



For further support, please contact us at info@orbbec3d.com.

Just an update on this. Anyone who bought a defective Orbbec sensor will not get any refund, or replacement, even if you complained about it at the time of purchase, and they told you they were “working on it”.
They basically tell you to “buy a new one” if you want to have a non defective sensor.
I have had a lot of problems with Orbbec sensors over the whole year I’ve been developing on them.

  • There are the black lines which appear out of the box and require an special software you only get after contacting Orbbec to get it fixed
  • The color-depth registration is off, as it has been pointed out many times in this forum
  • Astra Pro’s (And Persee’s) RGB sensor does not work with OpenNI or any pre Astra 2 SDK, a fact they do not announce out in public, which they blame on the sensor being an UVC camera (which doesn’t really matter, since there are cameras like the Xtion 2 which are UVC cameras, but also work under OpenNI)
  • Persee is sold as being “Ubuntu” compatible, but none of the images Orbbec provide are stable enough to work well, not there have been ANY new releases for over a year
  • Astra and Astra S, have an almost secret SXGA 5fps mode, which can only be triggered by tricking OpenNI (Or Astra SDK) to think it works at 30fps. In Astra, you are unable to mirror or register with color in this mode, or the depth data gets corrupted
  • Astra SDK, which is sold as the “Main” SDK for Orbbec cameras has never had a single feature complete stable release. Not even the newer betas of the SDK are able to do simple things like deactivate White Balance.

Orbbec offers great products on paper, but their quality and support is abysmal.

Would be interested to know more about the “special software” to fix black lines - which lines are you talking about - and what does the software do?

And FWIW - we have now had 2 orbbec cameras simply cease to operate - an ASTRA S and an ASTRA PRO.
Not greatly impressed with the build quality :frowning:

And no after shipping the half way round the world already - its not practical to send the back anywhere :frowning:

I suspect another manufacturer will wind up getting our custom at the current rate of failures and poor support.


We sincerely apologize for any inconvenience these may have caused you. We are working very hard to bring the best possible products in the market. These suggestions are very important for us to improve our future releases. We are here to help if the product is not able to meet your expectation at current stage. Please do not hesitate to contact us at info@orbbec3d.com if we can be of any further assistance.

They call it the “Enhanced Filter Tool”, and it changes some filter for depth processing from or to hardware or software.

One of our Astra Cameras have a cable that is about to snap from the back just from regular use. Not to mention that when we received our Persee camera, the inside of the box was dirty.

Because of the problems I pointed out before, our company is about to shift development from Orbbec cameras to Realsense or Xtion 2.

The enhanced filter tool has been around for a while - but didnt think it worked correctly with the new 2.0sdk.
I must have a look at it again some time.


We’ve been using Astra cameras for a while.
We deployed lots of these cameras in the field, running for weeks at a time without any issue. We only had 1 Astra S that was dead (we purchased a lot of these cameras)
The new cameras shipped 2018 fixed most of the problems we were having.