Persee Ubuntu 14 wifi device not ready

I’ve update the ROM of my Persee to Ubuntu14 OS, but the Wi-Fi Network(right-bottom of screen) always shows “device not ready”.
I can’t use wifi connection.
Any solution?


have you tried these suggestions by @Jesse?

No, I use win7. And it didn’t show any error message when updating the ROM.
Besides, I have two Persee which bought at different time.
One can use wifi, the other one can’t.

I meant this part of the post above:

The WIFI does not always start on boot. Doing ifdown wlan1 / ifup wlan1 fixes this. Not sure if related, but /etc/rc.local appears to do this on boot every time - is this needed? In addition, the WIFI doesn’t always connect to known networks automatically, but doing nmcli con up id fixes it. Could probably just add this in a script that’s called via rc.local.

I’ve tried. It shows “Ignoring unknown interface wlan1=wlan1” when ifup wlan1.

Hi! I am having the same issue as you. Did you figure out the solution?
Thank you

No. I refreshed it to Ubuntu 16.04, then wifi connection can be used.