Astra Pro RGB on OSX


I can’t view the Astra Pro RGB feed on OSX. I’ve tried accessing the feed through the SDK (SimpleColorViewer-SFML, SimpleStreamViewer-SFML) and it just shows a black screen. I tried accessing the camera through other applications (skype, facetime, photobooth) with no success. The camera just doesn’t show up as an available input.

The depth streams (SimpleDepthViewer-SFML, etc.) work fine.

System specs

macOS Sierra 10.12.1
Macbook Pro (Early 2013)
cmake 3.6.2

also tested on:
macOS Sierra 10.12
Macbook Pro (Early 2015)
cmake 3.6.1

Tried Solutions

Debug Samples

I compiled the samples using ./build_samples, and later ./build_samples -d. Everything compiles successfully. astra.log has no content on both occasions, even after running some samples.

Other OSX Applications

Some other posters [0, 1] have been able to view the camera in other applications, but I haven’t be able to do that. When I open skype/facetime/photobooth, they all only show the built in camera as the only option.

[0] Problem with RGB camera on Astra Pro
[1] Color Image Not Firing On Frame Event


I tried to access the raw camera feed through OpenCV [2] - no luck. The only available camera is my built in one.

[2] Video capture on MacBook - OpenCV Q&A Forum


This looked promising [3] but the download link is broken that’s listed in that thread. I’m guessing if facetime/skype etc. aren’t recognizing the camera than there’s no reason to believe that OpenNI would be able to access the feed.

[3] Compatibility Astra Pro and OpenNI2 - #3 by josh

Other information

I’ve run ioreg -p IOUSB and the Astra shows up as a USB device. Relevant output lines:

 |     +-o Astra Pro HD Camera@1a121000  <class AppleUSBDevice, id 0x10000afbb, registered, matched, active, busy 0 (10 ms), retain 16>
 |     +-o ASTRA Pro@1a122000  <class AppleUSBDevice, id 0x10000afd3, registered, matched, active, busy 0 (15 ms), retain 20>

Can any devs respond on this issue? Pretty disappointing to buy a product and have it not work out of the box.

Have you tried it on an other OS? Just to make sure that the camera works fine.
I never had any problem using Astra on windows or Linux.

However, I am experiencing the same problem on Persee Ubuntu 14. The RGB Does not play.

Have you found a solution to your problem?


I’m having the same issue as @splendidgoose when trying to run the Astra SDK samples, except that none of them work (SimpleDepthViewer-SFML doesn’t even work).
I can see the Orbbec Persee in my USB devices in System Informations.

I first tried running ofxOrbbecAstra on of_v0.9.8, it built but I get a black screen, with no console output. Maybe it’s because my OF version is too recent, but I suppose if I can’t get running the Astra SDK samples, then OF shouldn’t work neither.

I also tried running OpenNI samples from the Orbbec Astra SDK 2.0.8 Beta2 Mac Mirror that can be found on the develop page, but I get this error :
SimpleViewer: Device open failed: DeviceOpen using default: no devices found

I’m quite confuse since I can see my Orbbec Persee in my Information System report.

##System specs

  • macOS High Serria 10.13.3
  • MacBook Pro (13-inch, 2017, Four Thunderbolt 3 Ports)
  • cmake version 3.10.2
  • Orbbec Persee linked by microUSB to my Mac

I’ve just tweeted to the @Orbbec account to get some information about HighSerria compatibility, I’ll keep the forum updated with the news.